Administration

Vous êtes ici : Accueil » programmation » Exporter des données Excel vers une Base de données MySQL

Exporter des données Excel vers une Base de données MySQL

Tout d'abord, créez un fichier Excel le titre des colonnes c'est à dire la première colonne sera le nom des champs de la tables.

 1-

Nommez le nom de la feuille qui sera le nom de la table

Entrez les données dans chaque colonne.

Cliquez sur enregistrer sous, puis nommez le fichier et dans type de fichier  le document avec type de fichier "feuille de calcul open document"

Créez une base de données dans PHPMYADMIN, importez le fichier 

Dans la base SQL, choisissez "open document"  dans options spécifiques au format "cochez toutes les cases"

La première case signifie que les titres des données seront le champ de la première colonne

 

Pensez à modifier le style de la bordure des cellules. Mercii

2ème solution, que je trouve être la meilleure

 

Nommez les colonnes du fichier excel.

renommez le nom de la feuille qui sera le nom de la table.

ENREGISTRER LE FICHIER SOUS : TYPE DE FICHIER: Texte CSV (.csv) puis enregistrer le. Puis choisissez le  jeu de caractères. Exemple  si la base ou la tabse est UTF-8, choississez donc le caractère UTF-8

La base de donnée étant déjà créée et la table également. Importer le fichier dans la base de données. 

voila


Supprimer ou extraire chiffres dans cellule alphanumérique

=SI(ESTNUM(CNUM(GAUCHE(A2;TROUVE(" ";A2))));DROITE(A2;NBCAR(A2)-TROUVE(" ";A2));A2)


Supprimer ou extraire les lettres dans cellule alphanumérique

=GAUCHE(B57;CHERCHE(" ";B57))

------------------------------------------------------------------------------------

à mettre les formules dans la colone de droite 

 

Pour  copier coller le résultat obtenu: faire copier/coller => coller seulement=> texte


Transformer deux colonnes en une colone

=a1 & "  " & b1  en separant par des espaces

=A1 & " " & B1  en separant par des espaces; => , / par exemple


Date de publication:   04/06/2018 par admin

Dernière modification: le 15/08/2018 21:05:18 par admin

Les cours de PHP sur toutes les facettes.

Les cours de PHP sur toutes les facettes.

Page précédent 172 173 176 177 178 Page suivante

Laisser un commentaire





elmntw37


zack77 Jeudi 16 Août 2018

Aucun commentaire pour le moment concernant le sujet « Exporter des données Excel vers une Base de données MySQL »!